Outage
Incident Report for TradeGecko
Resolved
And we're fully operational again, we apologize for the inconvenience.
Posted almost 3 years ago. Mar 04, 2015 - 14:08 GMT+08:00
Identified
We're currently experiencing some unplanned downtime, caused by human error.
We apologize for this and working hard to get TradeGecko back up as quickly as possible
Posted almost 3 years ago. Mar 04, 2015 - 14:05 GMT+08:00