Login Issues for some London customers
Incident Report for TradeGecko
Resolved
British Telecom ISP has fixed their DNS server. Web interface issues for British Telecom ISP users are now resolved.
Posted over 2 years ago. Aug 25, 2015 - 01:30 GMT+08:00
Identified
We seeing issues with some customers in London are unable to access the TradeGecko system.
The issues are specific to British Telecom ISP users.

Our service providers are working with British Telecom to resolve the issues, in the meantime an (advanced) workaround can be found at https://developers.google.com/speed/public-dns/docs/using?hl=en
Posted over 2 years ago. Aug 24, 2015 - 21:30 GMT+08:00