Issues with our database provider
Incident Report for TradeGecko
Resolved
All services are back up again. We apologize for any incovenience
Posted over 2 years ago. Sep 09, 2015 - 22:20 GMT+08:00
Investigating
One of our database provider is experiencing availability issue. We're working with our provider to restore service.
Posted over 2 years ago. Sep 09, 2015 - 22:03 GMT+08:00