SSL Issue with B2B stores
Incident Report for TradeGecko
Postmortem

On Tuesday, 24 July 2018 beginning from 00:00 UTC to 01:58 UTC, B2B stores on TradeGecko could not be accessed through HTTPS. During this time, some of your customers may have seen a security warning that the connection to the B2B store was not secure. Customers who have a custom domain for the B2B store were not affected by this incident.

This partial outage was caused due to the expiration of our gogecko.com domain's SSL certificate. We have added safeguards in order to make sure that we never miss expiring certificates in the future.

We would like to apologise for the impact that this outage may have had on your business. We take any incident that affects the availability of our B2B stores seriously and are tightening up our monitoring to make sure that your customers have a stable and secure experience.

Posted about 1 year ago. Jul 24, 2018 - 12:01 GMT+08:00

Resolved
SSL for all B2B stores are operational again. Thank you for your patience.
Posted about 1 year ago. Jul 24, 2018 - 10:03 GMT+08:00
Investigating
We are currently investigating this issue
Posted about 1 year ago. Jul 24, 2018 - 09:39 GMT+08:00
This incident affected: B2B eCommerce.