Intelligence Reporting Database Under Maintenance
Incident Report for TradeGecko
Resolved
This incident has been resolved.
Posted 10 months ago. Dec 20, 2018 - 16:56 GMT+08:00
Monitoring
We have completed the maintenance work on the data base that generates intelligence reports. The data in the intelligence reports is now being progressively updated.
Posted 10 months ago. Dec 19, 2018 - 15:23 GMT+08:00
This incident affected: Intelligence & Reporting.